Results 1 to 5 of 5
  1. #1
    Registered User leahbear's Avatar
    Join Date
    Feb 2012
    Location
    Vancouver, BC
    Posts
    62
    Thanks
    3
    Thanked 15 Times in 13 Posts

    Default vitex -> O but no AF

    I started taking vitex on cd10 of this last cycle and probably ovulated on cd16 (egg-white cervical mucus and bbts went up and stayed up). My temperature stayed up for 17 days which is unusual for me, whenever I've managed to ovulate in the past I get my period 14 days later, but I've read that vitex can make your luteal phase longer. The weird thing is that my temps have been down for 3 days now and still no period! I've been charting my cycles for a couple of years now and I'm used to seeing stretches of no ovulation with no AF, but this is the first time I've ovulated with no AF. My body gets ready to ovulate every month at the same time, increasing cervical mucus up to eggwhite, but it only manages about 1/3 of the time. The other times my temperatures don't go up and no AF. Just wondering if anyone else experienced anything similar when first starting vitex. I think it's a step in the right direction as I had AF last month so I wouldn't normally ovulate again for another month or 2 or 3. I made a ton of changes to my diet this month too so maybe my body is just confused.

  2. #2
    Registered User cielos's Avatar
    Join Date
    Oct 2011
    Posts
    33
    Thanks
    0
    Thanked 7 Times in 4 Posts

    Default

    Vitex can make your cycles weird sometimes. If this is your first cycle taking it, you will probably notice a lot of weirdness. You may notice some unusual cycle changes next cycle, too.

    If you started taking is CD 10, then it is possible you in turn delayed your period by that long as well.
    thin cyster

    medication: metformin 1000mg, saw palmetto, vitex, and DIM

    diet: low carb and regular cardio exercise + Pilates

    Hidden Content DS 1 Hidden Content DS2 Hidden Content surprise pregnancy and 5 wk loss 03 06 12

  3. #3
    Registered User SmileyGirl73's Avatar
    Join Date
    Apr 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Vitex and no AF

    Quote Originally Posted by leahbear View Post
    I started taking vitex on cd10 of this last cycle and probably ovulated on cd16 (egg-white cervical mucus and bbts went up and stayed up). My temperature stayed up for 17 days which is unusual for me, whenever I've managed to ovulate in the past I get my period 14 days later, but I've read that vitex can make your luteal phase longer. The weird thing is that my temps have been down for 3 days now and still no period! I've been charting my cycles for a couple of years now and I'm used to seeing stretches of no ovulation with no AF, but this is the first time I've ovulated with no AF. My body gets ready to ovulate every month at the same time, increasing cervical mucus up to eggwhite, but it only manages about 1/3 of the time. The other times my temperatures don't go up and no AF. Just wondering if anyone else experienced anything similar when first starting vitex. I think it's a step in the right direction as I had AF last month so I wouldn't normally ovulate again for another month or 2 or 3. I made a ton of changes to my diet this month too so maybe my body is just confused.

    Hi - I was just wondering how you are going on cycle 2 on vitex? I am experiencing exactly the same thing on cycle 1. I'm nearly 39 so hoping it is the Vitex delaying AF by 6 days (so far) and high temps and not early menopause! I started it on day 14 so someone else said it may delay my cycle by 14 days. I'm also having awful cramps and sore boobs (for the past 12 days) but had a preggo blood test yesterday and is was negative (very low score so no chance of it changing) so I'm deffo not preggo.

  4. #4
    Registered User leahbear's Avatar
    Join Date
    Feb 2012
    Location
    Vancouver, BC
    Posts
    62
    Thanks
    3
    Thanked 15 Times in 13 Posts

    Default

    I just skipped bleeding that cycle entirely, then a new cycle started and I bled at the end of that one. The vitex seems to be making my cycles longer. Normally if I missed bleeding one cycle but then bled the next time the whole cycle would be about 60 - 62 days, but after starting the vitex the same type of cycle lasted 73 days. And my luteal phase was 16 days this last time instead of my usual 14.

  5. #5
    Registered User Misscruella's Avatar
    Join Date
    Apr 2012
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I stopped taking items because it made me crampy and break out. Must just not be for me

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •